Third Party Boards Won’t Compile in Arduino IDE after an Upgrade? Read on to see how to fix it

So, I finally upgraded my Arduino IDE software to 1.6.7 and, as a result, none of the ATTINY boards would compile…Neither the digispark or Adafruit trinket. All I got was the error:
Board digispark-tiny (platform avr, package digistump) is unknown.
for the Digispark.

After some research, I found a solution for Windows:

  • You need to remove all of the board definitions from Arduino.
  • Open Board Manager and REMOVE all non-Arduino boards you have installed
  • Close board manager
  • Goto Preferences and remove the board url’s there
  • Next, open Explorer in Windows and navigate to: C:\Users\youruserdirectory\AppData\Local\Arduino15\packages and remove the directories under packages
  • Restart Arduino and then add the boards back

This should take care of the problem. You can fix it in Linux by following the same directions. The Linux equivalent of the Windows User directory would be your user directory\Arduino15…

Advertisements

One thought on “Third Party Boards Won’t Compile in Arduino IDE after an Upgrade? Read on to see how to fix it

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s